API Responses degraded

Incident Report for JustiFi

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 21:07 UTC

Monitoring

The API times appear to have returned to normal.
Posted Oct 21, 2025 - 21:03 UTC

Identified

We are experiencing slow API response which are causing occasional errors for Payment APIs. We are monitoring and changing resource accordingly.
Posted Oct 21, 2025 - 20:59 UTC
This incident affected: Payments API and Checkout API.