Terminal Payments Issue

Incident Report for JustiFi

Postmortem

Posted Aug 04, 2025 - 17:31 UTC

Resolved

This incident has been resolved. A post morterm and RCA will follow Monday morning.
Posted Aug 02, 2025 - 15:46 UTC

Update

We have been observing steady successful terminal payments, the incident has been resolved.
Posted Aug 02, 2025 - 15:46 UTC

Monitoring

The service is back up and functioning. All terminals have been reconciled and should be available for processing as usual.
Posted Aug 02, 2025 - 15:32 UTC

Identified

Our terminal payments are currently experience an issue due to reconciliation with expired credentails. We are updating the environment.
Posted Aug 02, 2025 - 15:24 UTC
This incident affected: Checkout API.