Downstream Gateway API Latency issues

Incident Report for JustiFi

Resolved

Our downstream payment API latency impacted tokenization and payments during the following time windows this morning:

- Intermittent windows from 13:20-13:53UTC
- 14:20-14:21UTC

Latency has been normal since 14:21UTC. We will continue to observe today and follow up with more information during business hours.
Posted Sep 13, 2025 - 15:03 UTC

Monitoring

It appears that the downstream API latency has returned to normal, we are continuing to observe.
Posted Sep 13, 2025 - 14:52 UTC

Identified

We are experiencing slow responses from our downstream payment gateway this morning. We are observing and will provide an updates as we know more.
Posted Sep 13, 2025 - 14:40 UTC
This incident affected: Payments API.